# Table of Contents

Navigating Oracle Applications ........................................................................................................ 1
  R11i Navigating Oracle Applications ................................................................................. 1
  Main Content .................................................................................................................... 2

Logging On and Off of Oracle Applications .............................................................................. 3
  Logging On to Oracle Applications .................................................................................. 4
  Choosing a Responsibility .............................................................................................. 5
  Navigator .......................................................................................................................... 6
  Expanding or Collapsing the Navigation List .................................................................... 7
  Expanding or Collapsing Several Items ............................................................................. 8
  Logging Off of Oracle Applications .................................................................................. 9

Using Forms and Menus ......................................................................................................... 11
  Navigator Window .......................................................................................................... 12
  Form Terminology ......................................................................................................... 13
  Field Colors .................................................................................................................. 17
  Menus and Special Areas ............................................................................................... 18
  File Menu ..................................................................................................................... 19
  Edit Menu .................................................................................................................... 21
  View Menu .................................................................................................................. 23
  Folder Menu .................................................................................................................. 25
  Tools Menus .................................................................................................................. 26
  Window Menu ............................................................................................................... 27
  Help Menu ................................................................................................................... 28
  Commonly Used Commands ............................................................................................ 29
  Keyboard Shortcuts ....................................................................................................... 30
  The Toolbar .................................................................................................................... 31
  Message and Status Lines ............................................................................................... 33
  Changing Your Password ............................................................................................... 34
  Switch Responsibility ..................................................................................................... 35
  Top Ten List .................................................................................................................. 36
  Placing Documents on the Navigator ............................................................................... 37

Entering Data Using Forms ....................................................................................................... 39
  Creating New Records .................................................................................................... 40
  Deleting Records .......................................................................................................... 41
  Using a List of Values ..................................................................................................... 42
  LOV Shortcuts ............................................................................................................... 43
  AutoSelection and List Search .......................................................................................... 44
  Long-List Fields .............................................................................................................. 45
  Using Calendars .............................................................................................................. 46
  Using the Editor .............................................................................................................. 47
  Clearing Data ................................................................................................................ 48
  Copying Data from a Record ............................................................................................ 49
  Saving a Record ............................................................................................................. 50

Searching for Data Using Forms ............................................................................................... 51
  Using the Find Window ................................................................................................. 52
  Using Query Mode ......................................................................................................... 53
  Query Operators ........................................................................................................... 54
  Retrieved Records ........................................................................................................ 55

Accessing Online Help ............................................................................................................ 57
  IITA online help............................................................................................................ 58
  Using Window Help ....................................................................................................... 59
  Using Online Help .......................................................................................................... 60
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Searching for Help Information</td>
<td>61</td>
</tr>
<tr>
<td>Search Syntax</td>
<td>62</td>
</tr>
<tr>
<td>Oracle Applications Library</td>
<td>63</td>
</tr>
<tr>
<td>Error Messages</td>
<td>64</td>
</tr>
<tr>
<td>Record History</td>
<td>65</td>
</tr>
<tr>
<td>About Oracle Applications</td>
<td>66</td>
</tr>
<tr>
<td>Running Reports and Programs</td>
<td>67</td>
</tr>
<tr>
<td>Submitting a Request</td>
<td>68</td>
</tr>
<tr>
<td>Submission Schedule</td>
<td>69</td>
</tr>
<tr>
<td>Upon Completion</td>
<td>70</td>
</tr>
<tr>
<td>Finding Requests</td>
<td>71</td>
</tr>
<tr>
<td>Reprint</td>
<td>72</td>
</tr>
<tr>
<td>Requests</td>
<td>73</td>
</tr>
<tr>
<td>Four Phases of a Concurrent Request</td>
<td>75</td>
</tr>
<tr>
<td>Pending Phase</td>
<td>76</td>
</tr>
<tr>
<td>Running Phase</td>
<td>77</td>
</tr>
<tr>
<td>Completed Phase</td>
<td>78</td>
</tr>
<tr>
<td>Inactive Phase</td>
<td>79</td>
</tr>
<tr>
<td>Canceling or Holding Requests</td>
<td>80</td>
</tr>
<tr>
<td>Changing Request Options</td>
<td>81</td>
</tr>
<tr>
<td>Managing an Attachment to a Form</td>
<td>83</td>
</tr>
<tr>
<td>The Disabled Attachments Icon</td>
<td>84</td>
</tr>
<tr>
<td>Adding a New Attachment</td>
<td>85</td>
</tr>
<tr>
<td>What You Can Do with Attachments</td>
<td>86</td>
</tr>
<tr>
<td>Copying Attachments</td>
<td>87</td>
</tr>
<tr>
<td>Viewing Attachments</td>
<td>88</td>
</tr>
<tr>
<td>Examining the Attachments Window</td>
<td>89</td>
</tr>
<tr>
<td>Attachments Window Fields</td>
<td>90</td>
</tr>
<tr>
<td>Customizing the Presentation of Data</td>
<td>91</td>
</tr>
<tr>
<td>What You Can Do with Folders</td>
<td>92</td>
</tr>
<tr>
<td>Folders</td>
<td>93</td>
</tr>
<tr>
<td>Querying Records in a Folder</td>
<td>94</td>
</tr>
<tr>
<td>Resetting Query Criteria</td>
<td>95</td>
</tr>
<tr>
<td>Folder Tools</td>
<td>96</td>
</tr>
<tr>
<td>Direct Manipulation Techniques for Folders</td>
<td>97</td>
</tr>
<tr>
<td>More Folder Tasks</td>
<td>98</td>
</tr>
<tr>
<td>Setting Personal Profile Options</td>
<td>101</td>
</tr>
<tr>
<td>Setting Personal Profile Values</td>
<td>102</td>
</tr>
<tr>
<td>Profile Option Values</td>
<td>103</td>
</tr>
<tr>
<td>Personal Profiles Values</td>
<td>104</td>
</tr>
<tr>
<td>More Personal Profiles Values</td>
<td>105</td>
</tr>
<tr>
<td>Hints and Tips</td>
<td>106</td>
</tr>
</tbody>
</table>
Typographic Conventions in Navigation Paths

This course uses simplified navigation paths, such as the following example, to direct you through Oracle Applications.

(N) Invoice > Entry > Invoice Batches Summary (M) Query > Find (B) Approve

This simplified path translates to the following:

1. (N) From the Navigator window, select Invoice then Entry then Invoice Batches Summary.
2. (M) From the menu, select Query then Find.
3. (B) Click the Approve button.

Notations:

(N) = Navigator  (I) = Icon
(M) = Menu  (H) = Hyperlink
(T) = Tab  (B) = Button

Typographical Conventions in Help System Paths

This course uses a “navigation path” convention to represent actions you perform to find pertinent information in the Oracle Applications Help System.

The following help navigation path, for example—

(Help) General Ledger > Journals > Enter Journals

—represents the following sequence of actions:

1. In the navigation frame of the help system window, expand the General Ledger entry.
2. Under the General Ledger entry, expand Journals.
4. Review the Enter Journals topic that appears in the document frame of the help system window.
After this course, you should be able to:

• Logon and off of Oracle Applications
• Use forms and menus
• Enter data using forms
• Search for data using forms
• Access online help
• Run and monitor reports and programs
• Managing an attachment to a form
• Customizing the presentation of data
• Setting personal profile options

Course Overview
This manual discusses the basic features of accessing and navigating within Oracle Applications, Release 11i. You will learn to enter data, retrieve information in the form of a query, maintain data, and access online help. Additionally, concurrent processing and standard report submission will be discussed.

It is intended for all end users of Oracle Applications as a prerequisite to any applications course.
Logging On and Off of Oracle Applications
Logging On to Oracle Applications

1. Run Internet Explorer.
2. Choose “IITA Oracle” from the Favorites bar.
3. Type your Username and Password, click Connect or press Enter.

To use Oracle Applications productively, you need to understand the various components of a form, the menu paths, and keystrokes necessary to access and navigate within the system to perform your various job tasks.
Follow the steps described above to log into the system.
Choosing a Responsibility

From the Personal Homepage click on a link to the responsibility

1. Click on the “Main Menu” tab and then choose a responsibility from the Home Page. These are listed under Applications as shown above.

For example, you could choose “Purchasing Requestor”.

Responsibility Assignments

Each user has at least one responsibility and several users can share the same responsibility. You will be allocated appropriate responsibilities in the system. The majority of users will have the “Purchasing Requestor” responsibility, which allows them to complete MRIs and RFPs in the system. Click on the underlined link in the Application section to select your responsibility.
Navigator Window

The Navigator window displays the name of the responsibility you select in the title bar. Use this window to navigate to a form so you can perform a specific task, such as entering an MRI. You can navigate to the forms that are displayed in a navigation list on the left side of the Navigator window. You can click on the tabs to access different regions.
Expanding or Collapsing the Navigation List

- Choose one of the following methods to expand an item to its next sublevel form:
  - Double-click the item.
  - Select the item and choose Open.
  - Select the item and choose Expand.
- To collapse an expanded item, select the item and choose Collapse.

Using the Navigation List

Each user can access the Oracle Applications forms in several ways so that they can use the system quickly, according to their own computer style. Use the various buttons on the Navigator to manipulate list items.
Expanding or Collapsing Several Items

• To expand or collapse several items at once, choose one of the following buttons:
  – Expand All Children expands all the sublevels of the currently selected item.
  – Expand All expands all the sublevels of all expandable items in the navigation list.
  – Collapse All collapses all currently expanded items in the navigation list.

Using the Navigation List (continued)
Click any of these buttons to expand or collapse several items listed on the Navigator Menu. These functions are also available in the Tools pulldown menu.
Note that the Expand All function can take a very long time to execute and is rarely of use. Use Expand All Children to see all items within a specific menu.
Logging Off of Oracle Applications

- (M) File > Exit Oracle Applications
- Use this method so that your username is cleared from system access.

Exiting Oracle Applications

(M) File > Exit Oracle Applications, to log off the system. It is important to exit the system in this manner, rather than any other, as this is the only way to ensure that your user name is cleared from system access. You can also close the MDI window.
Using Forms and Menus
The Navigator Window

Use the Navigator window to navigate to a form that lets you perform a specific business activity. The Navigator window is always present during your session of Oracle Applications and displays the name of your current responsibility in its window title.
Form Terminology

Oracle Applications Release 11i works specifically in a Web-enabled environment. It is important to understand the terminology of the components within an Oracle Applications form. Common terms used in Oracle Applications forms are listed below.

**Menu bar**—Use pull-down menus from this menu bar to navigate or perform actions within a form.

**Window**—An area where the user interacts with an application (Many windows can be open at one time and you can access these “overlapping” windows to perform data entry or data search activities.)

**Window title**—Text in the title bar that indicates the name of the window, and usually, context information pertinent to the information in that window.

**MDI window**—A master container window that houses all windows, toolbars, and application windows.

**Tool tips**—Iconic bubble help that you can use to determine the function of a button on the toolbar.
Form Terminology

Region—A logical grouping of fields set apart from other fields by a box outline

Region tab—A collection of regions that occupy the same space in a window where only one region can be displayed at a time

Field—An area in a window that displays data or enables you to enter data

Button—A graphic element that initiates a predefined action when you click it
Form Terminology (continued)

**Option button** — A button that indicates an individual selection is available within an option group

**Modal window** — A window that requires you to act on its content *before continuing*

**Scrolling region** — A region, containing a scroll bar, in which to view other fields

**Block** — An area of information relative to a specific business function or entity
Form Terminology

Record or Row—A set of one or more related data items from a table or view that are grouped for processing. The blue rectangle on the left is called the current record indicator. Sometimes, it appears as a two character–wide field, indicating that the current multi–record block supports a capability called drill–down. This is shown in the previous slide.

Check box—A box in which you can toggle between an on/off or yes/no state for a particular value

LOV icon—An icon that you can click to display a list of values (LOV) for the current field

Poplist—A poplist lets you choose a single value from a short list
## Field Colors

<table>
<thead>
<tr>
<th>Field Color</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>White</td>
<td>Allow data entry</td>
</tr>
<tr>
<td>Yellow</td>
<td>Require data entry</td>
</tr>
<tr>
<td>Gray with black text</td>
<td>Are display only</td>
</tr>
<tr>
<td>Blue</td>
<td>Indicate fields to use in Query-Enter mode</td>
</tr>
</tbody>
</table>

### What Field Colors Indicate

Each block contains fields you use to enter, view, update, or delete information. A field prompt describes each field by telling you what kind of information appears in the field or what kind of information you should enter in the field. Fields are color coded to indicate their type as follows:

- **White Fields**—allow data entry
- **Yellow Fields**—require data entry
- **Gray Fields with Black Text**—are display-only
- **Gray Fields with Grey Text**—are disabled fields.
- **Blue Fields**—indicate fields to use in Query-Enter mode

The term field generally refers to a text field, an area in a window that either displays data or allows you to enter data. However, a field can also include a button, check box, option group, or poplist.
Menus and Special Areas

Using Menus and Other Areas

Oracle Applications use a Multiple Document Interface (MDI). All windows are displayed inside a single container window, with a single toolbar, menu, message line, and status line attached to that window. The message line displays pertinent information for processing your form. The status line displays status information.

The pulldown menu bar includes the following menus: File, Edit, View, Folder, Tools, Window, and Help.

Use these menus to navigate through a form, to edit or retrieve data, or to perform various other actions.

In addition to the pulldown menu, you can access the following menu items by right mouse clicking on an item: Cut, Copy, Paste, Folder Menu, and Help.
File Menu

For a complete description of all menus go to:
(M) Help > Oracle Applications Library > Library > Oracle Applications User’s Guide > Getting Started > Using Menus

Using the File Menu from the Menu Bar
New—Creates a new record in the active form.
Open—Opens the detail screen for the current selection.
Save—Saves any pending changes in the active form.
Save and Proceed—Saves any pending changes in the active form and advances to the next record.
Next Step—Updates the Process workflow in the Navigator by advancing to the next step in the process.
Export—Exports information in your current form to a browser.
Place on Navigator—Creates an icon in the Documents tab of the Navigator which can be used to recall the active form and its current record.
Log on as a Different User—Allows you to log on to Oracle Applications again as a different user.
Switch Responsibility—Allows you to change the responsibility in effect for your current log on.
Print…—Prints your current window. An application may override this action to instead allow printing of one or more specific reports.

Close Form—Closes all windows of the current form.

Exit Oracle Applications—Quits Oracle Applications.
Edit Menu

Using the Edit Menu from the Menu Bar

**Undo Typing**—Undoes any typing done in a field before the field is exited and returns the field to the most recent value.

**Cut**—Cut the current selection to the clipboard.

**Copy**—Copy the current selection to the clipboard.

**Paste**—Paste the contents of the clipboard into the current field.

**Duplicate Record Above**—Copies all values from the prior record to the current record.

**Duplicate Field Above**—Copies the value of the current field from the prior row.

**Clear Record**—Erases the current record from the window.

**Clear Field**—Clears the data from the current field.

**Clear Block**—Erases all records from the current block.

**Clear Form**—Erases any pending changes from the current form.

**Delete**—Deletes the current record from the database.

**Select All**—Selects all records (for blocks with multi-select).
Deselect All—Deselects all selected records except for the current record (for blocks with multi-select).

Edit Field…—Displays the Editor window for the current field.

Preferences Change Password—Displays the Change Password dialog box.

Preferences Profiles—Displays the Profiles window.
Using the View Menu from the Menu Bar

**Show Navigator**—Displays the Navigator window.

**Zoom**—Invokes custom defined zooms.

**Find**—Displays the Find window to retrieve records.

**Find All**—Retrieves all records.

**Query by Example Enter**—Invokes 'Enter Query' mode to enter search criteria for a query-by-example.

**Query by Example Run**—Executes the query-by-example.

**Query by Example Cancel**— Cancels the query-by-example by exiting from 'Enter Query' mode.

**Query by Example Show Last Criteria**—Recovers the search criteria used in the previous query-by-example.

**Query by Example Count Matching Records**—Counts the number of records that would be retrieved if you ran the current query-by-example.

**Record First**—Moves the cursor to the first record.

**Record Last**—Moves the cursor to the last record.
Translations—Displays the Translations window.
Attachments—Displays the Attachments window.
Summary/Detail—Switch between the summary and detail views of a combination block.
Requests—Displays the Request window.
Folder Menu

Using the Folder Menu from the Menu Bar

For some forms, you can personalize the presentation of data within a form by using a folder definition. With a folder definition you can modify the width, sequence, and prompts of the fields you want to display. Additional features of a folder definition are:

Displaying only those fields you are interested in viewing
Displaying a subset of records based on your specific criteria
Automatically querying for a subset of records each time you open a specific folder
Keeping your folder customizations private or making them public for others to use
Making your customizations the default layout for a folder

Note: Using Folders is covered in detail in the upcoming section “Customizing the Presentation of Data.”
Tools Menus

Using the Tools Menu from the Menu Bar

The Tools menus may contain up to fifteen product-specific entries. Examples of product-specific entries may include a list of commonly used Inquiry windows in the application, or a commonly used window that a user may want to display for a quick reference.

In some applications, up to two additional menus may appear after the Tools menu. These menus are usually labeled “Reports” and “Actions”, but may be different depending on the products that are being used. Like the Tools menu, these menus each allow up to 15 product-specific entries.
Window Menu

Using the Window Menu from the Menu Bar

**Cascade**—Displays any open windows in a "cascaded" or stair-stepped fashion.

**Tile Horizontally**—Displays any open windows in a horizontally "tiled" (non-overlapping) fashion.

**Tile Vertically**—Displays any open windows in a vertically "tiled" (non-overlapping) fashion.

**1 (Title of Open Window)**—Displays a list of open windows titles in the order in which they are stacked.
Using the Help Menu from the Menu Bar

**Window Help**—Displays Help for the current window

**Oracle Applications Library**—Displays a window that lists all available Oracle Applications Help text

**Keyboard Help...**—Displays the current mapping of specific functions and menu options

**Diagnostics**—There are multiple Diagnostics menus used for coding and debugging. This will only be highlighted if the System Administrator has provided this functionality for your responsibility.

**Record History**—Displays information about who created and updated the current record.

**About Oracle Applications**—Displays information about the current window and application. The information supplied here can be very useful when reporting problems with the forms you are using to the MIS department.
Commonly Used Commands

- (M) File > Save
- (M) File > Exit Oracle Applications
- (M) File > Switch Responsibility
- (M) File > Close Form
- (M) Edit > Preferences > Change Password
- (M) View > Find
- (M) View > Query By Example
- (M) Help > Window Help
- (M) Edit > Clear Record

The commands listed above are the ones you will use the most when using Oracle. Remember that these Navigation paths (i.e. (M) File > Save) direct you to options/functions in Oracle. For example, (M) File > Save is the equivalent of:
Choose File on the menu bar and then select Save.

Further information about navigation paths is available at beginning of this guide, “Typogrpahical Conventions in Navigation Paths”.
Using Keyboard Shortcuts

Experienced Oracle Applications users can bypass the menu by using a keyboard shortcut, a specific combination of keystrokes that performs the same function as a corresponding menu item. Oracle Applications assigns many commonly used functions, such as Run Query, Save, or Clear Record to keyboard shortcuts.

You can display a list of the keyboard shortcuts that map to your computer terminal's keyboard at any time.

To display a list of keyboard shortcuts:
(M) Help > Keyboard Help...
When you finish scrolling through the listing, click OK to close the window.
The Toolbar

Using the Toolbar

The toolbar is a collection of iconic buttons, where each button performs a specific action when you choose it. Each toolbar button replicates a commonly-used menu bar item. Depending on the context of the current field or window, a toolbar button can be enabled or disabled. You can display help or a tool tip for an enabled toolbar button by holding your mouse over the button.

**New** - Creates a new record in the active form.

**Find...** - Displays the Find window to retrieve records.

**Show Navigator** - Displays the Navigator window.

**Save** - Saves any pending changes in the active form.

**Next Step** - Updates the Process workflow in the Navigator by advancing to the next step in the process. It also saves any pending changes in the active form.

**Print** - Prints the current screen that the cursor is in. In some cases it may print a report associated with the current data.

**Close Form** - Closes all windows of the current form.

**Cut** - Cut the current selection to the clipboard.

**Copy** - Copies current selection to the clipboard.
Paste - Pastes from the clipboard into the current field.
Clear Record - Erases the current record from the window.
Delete - Deletes the current record from the database.
Edit Field... - Displays the Editor window for the current field.
Zoom - Invokes custom-defined Zoom (drilldown behavior).
Translations... - Invokes the Translations window (if multiple languages are installed).
Attachments... - Invokes the Attachments window. If one or more attachments already exist, the icon changes to a paper clip on a piece of paper.
Folder Tools - Displays the folder tool palette.
Window Help – Displays help for the current window.
Message and Status Lines

The **message line** is located at the bottom of the window and displays helpful hints or messages when you encounter a minor error. It is sometimes useful to look here when you need help on performing a particular action.

**Status Line**

The **status line** indicates current status information about the field/record you are viewing. It can contain a record indicator, for instance Record: 1/1—this example indicates that the current record is one of one records in the current block. If an undetermined number of records have been retrieved, the message will appear as 1/?.

**Enter-Query** indicates the current block is in Query Mode, this will also be indicated by the fact that the fields have a blue background.

**List of Values** indicates that the field also has list of values (LOV) entries available.

**Activity Indicator**

Note that some functions in Oracle, such as running a large query, may take sometime to complete, such activity is indicated by the vertical bar moving left and right as shown.
Changing Your Password

Password Update
You can change your password at any time during your session. It will be in effect the next time that you log on.

How to Change Your Password
(M) Edit > Preferences > Change Password
Enter your old and new passwords and click OK.
Switch Responsibility

Responsibilities
You can switch your responsibility at any time during your session. You can then access functions pertinent to that responsibility

How to Switch Your Responsibility
(M) Edit > Switch Responsibility
Select a new responsibility from the list of values and click OK.
Using the Top Ten List

If there are forms that you use frequently, you can add them to a navigation top ten list located on the right side of the Navigator window. You can add a maximum of ten forms to the top ten list and you can create a different top ten list for each responsibility for which you have access. A top ten list is unique for the responsibility and user sign-on combination that you use.

**How to Create a Navigation Top Ten List**

1. Select a frequently used form from the navigation list by highlighting it in the Navigator window.
2. Click the right pointing arrow to add that form to the top ten list.
3. Click the left facing arrow to remove a form from your top ten list.
4. To open a form in your top ten list, type the number that precedes the form you want to open. You can also click on it and press Open, or double-click on it.

**Note:** Sometimes the form that you add changes names when it appears in the top ten listing. An example is that Suppliers becomes Vendors, or Orders, Returns becomes Order Workbench. Also note that the tenth entry is numbered 0 (zero), so it can be invoked by pressing a single keystroke also.
Placing Documents on the Navigator

(M) File > Place on Navigator

Using the Save to Navigator Option

Some Oracle Applications enable you to save a document to the Navigator for easy access when you first log into the system. The File menu will illuminate the Place on Navigator option when it is available within your application. One example is the Requests window of the SRS form.

The Documents tab on the Navigator window will display icons or list those documents that you have saved. This shortcut eliminates having to query the database to find your specific document. Instead, you can select it from the Navigator window and go directly to the window containing your document.

How to Access a Document from the Navigator Window

1. Select the Documents tab displayed at the Navigator window.
2. Select the document from the list of documents or document icons displayed to go directly to the applications form window for that document.

You can change the label of the document to whatever you like by pressing the Rename button. You can delete the document from your Navigator by pressing Delete. Note that this will not delete the actual document, only your shortcut to it.
Entering Data Using Forms
Creating New Records

Creating a New Record

When you add a new record to the database, Oracle Applications will move the current record down and insert a new blank row. You add a new record by entering information into this blank row. In most screens you are automatically on a new record when the form is opened, so you can just start entering the information.

After you finish entering the data for your new record, you must remember to click Save so that your newly added information will be written to the database. If you enter five new blank rows of information but do not click Save when you are finished, none of this newly added information will be updated in the database (the system will prompt you to save before you exit).

How to Create a New Record

(M) File > New. Or, click the New icon on the toolbar.

You can also press the down arrow on your keyboard to insert a blank row, if you are not in a table on the form. Additionally, some applications have a button labeled New, and clicking it will insert a blank row.

Type the new information into the blank row.

(M) File > Save or click the Save icon to save the new record.
Deleting Records

Deleting a Record from the Database
If you want to delete a record from the database, you must first display the record on your form and then click the Delete icon.

Note: This option is not always available. For example, in Oracle Applications you cannot delete a customer once they have been entered; you can only inactivate their status.

If you do not Save this new change to the database, the record is not truly deleted (the system will prompt you to save before you exit).

How to Delete a Record
(M) Edit > Delete, or click the Delete icon.
(M) File > Save or click the Save icon.

Note: You must Save after you have deleted to confirm the deletion, this is the same principle as the recycle bin in Windows, if you do not save then when you exit the form your deletions will be cancelled.
Using a List of Values

The List of Values (LOV) feature is very useful while entering data in Oracle Applications. It provides you with a powerful, easy-to-use data entry method that increases your accuracy and productivity. Using the LOV makes data entry an easy task for novice users, and experienced users can enter correct data with a minimum number of keystrokes.

Oracle Applications notifies you when a list of acceptable input values is available for a field by displaying the List icon in the field. When you display a list, the values appear in a window with a title that describes the contents.

By using the LOV feature, you can save time and enter data quickly without having to memorize or look up valid data for each field. You can choose data from an online list of valid input choices whenever you want. Additionally, you are relying on Oracle Applications to validate your input since you will know right away if your entry does not match an option from the LOV.
Choosing a Value from a List

To choose a value from a list for a field click the LOV icon in the field to display a list. If you do not want to view the entire list selection, you can reduce the length of a list, or select directly from the list by using some of the methods described below.

- Without clicking in the Find field, type the first character(s) of a value to reduce the list to only those values that match the characters you enter. This is also known as AutoSelection.
- Search for a value by clicking in the Find field, then enter your search criteria in the Find field and click the Find button.
- Select a value directly from the list by using the mouse to scroll through the list and then double-click the value to choose it, or click once on the value and then click OK to choose it.

Once you choose a value, the list window closes and inserts the value into the current field. To close a list window without choosing a value, select Cancel.
AutoSelection and List Search

**AutoSelection**

Using the list of values feature called AutoSelection you can select a valid name from the list with a single keystroke. When you display the list window, you can type the first character of the name you want in the Find field. If only one choice begins with the character you enter, AutoSelection selects the choice, closes the list window, and enters the value in the appropriate field.

**List Search**

You can use the AutoReduction feature to reduce a list when you know the first few characters of your name selection.

In the list window, enter any group of characters as search criterion in the Find field and click the Find button. You can use wildcard characters such as the percent sign (%) which represents any number of characters, or an underline (_), which represents a single character in your search criterion.

For example, to reduce a list to only those choices that contain the phrase “schedule,” you would type %schedule% in the Find field and click Find. In any of these list search queries, it does not matter whether you use uppercase or lowercase letters as the search is not case sensitive. Oracle searches all of the columns in the list.
Long-List Fields

If a field has a “long-list”—that is, a list of more than 100 values—when you try to display the LOV, Oracle Applications will display a window where you can enter list reduction criteria. Because it takes less time to display a reduced list than a complete long-list, Oracle Applications prompts you to enter the first few characters that occur in your value of interest to reduce the complete list. However, to view the entire long-list, enter the percent sign (%) at the prompt and all of the values will be displayed.

**Note:** To avoid excessive network traffic and reduced performance, try to enter specific criteria, other than just a percent sign (%), whenever possible.

**Power List**

The Power List feature provides an even faster method of data entry. If a field displays a List icon and you know the value you want, simply enter the first few characters of the value in the field and press [Tab]. Power List will complete the entry for you. You can also include wildcard characters with your entry. You do not need to display the list window. If more than one value matches the characters you specify, a list window containing those values is displayed. If no values match the characters you enter, a list window containing all the values appears.
Choosing a Date in the Calendar Window

Values in a date field can be typed directly (use DD-MMM-YYYY, e.g. 14-MAY-2001) or you can use a calendar to enter a valid value in a date field if the field displays the List icon. If your date field supports time, you can also use the Calendar window to choose a valid time with the date.

1. Put your cursor in a date field.
2. Click the List icon to display the Calendar window. The date value that appears below the calendar is called the selected date, which is either the value already in the field, the default value of the field, or the current system date.
3. Click on a date.
   
   **Note:** Disabled buttons that show dimmed text represent invalid days, which cannot be chosen. Similarly, if a date field is display only, you can display the Calendar window for the field, but you cannot change the date shown on the calendar.
4. Click OK to accept the selected date and close the window.
5. Click Cancel if you want to close the window without choosing a date.
Using the Editor

Update or edit scrollable fields easily

Search for and replace contents of fields

(M) Edit > Edit Field

Editing a Field

You can display an Editor window to view, enter or update the entire contents of a text field. The Editor window is especially useful for editing long text fields. A scrollable text field is a field in which the actual content is larger than what is displayed, but you can view the contents by scrolling through the field.

How to Use the Editor Window

(M) Edit > Edit Field.

You can enter a new value or edit the existing value in the Editor window. If the current field is a display-only field, then the Editor window appears in display-only mode.

You can also use the Editor window to search for a phrase and replace it with another phrase. Click the Search button in the Editor window to display a Search/Replace window. Then, enter a value in the Search For field, and enter the other value in the Replace With field. Click Search to search for the value, or click Replace or Replace All to search for the value and replace the first occurrence or all occurrences with your new value, respectively.

Once you are satisfied with the value in the Editor window, click OK to close the window and insert the value into the field.
Clearing Data

Clearing Data from a Form

You can clear data from the screen at almost any time. Typically, you will use this feature when you start to enter data into a field and then change your mind. Oracle Applications will think you are in the middle of processing a record and may not proceed with your next task until you clear the field.

The data you clear is simply erased from the screen and not deleted from the database.

Note: If the data is new and has never been saved to the database, it will be lost permanently when you clear it from the screen.

(M) Edit > Clear, and then choose the appropriate option, to clear a field, record, block, or form.

You can also clear some or all data from a field by highlighting the data and choosing (M) Edit > Cut or [Ctrl]+[X].
### Copying Data from a Record

Check your data because not all fields always copy!

<table>
<thead>
<tr>
<th>Item number</th>
<th>Quantity</th>
<th>Price</th>
<th>Discount %</th>
</tr>
</thead>
<tbody>
<tr>
<td>Item number</td>
<td>Quantity</td>
<td>Discount %</td>
<td></td>
</tr>
</tbody>
</table>

**Duplicating Data from a Previous Record**

To save time during data entry, you can duplicate data from a previous record if much of the data needs to be repeated again in the new record. You can use Cut, Copy, and Paste from the Edit menu or you can use the following techniques:

**Copying a Field Value from the Previous Record**

1. Enter a new record or query an existing record in your form.
2. (M) File > New or click the New icon to insert a new record after the existing record.
3. Place your cursor in the field whose value you want to duplicate.
4. (M) Edit > Duplicate Field Above, to copy the field value from the previous record into the current record.

**Copying All Field Values from the Previous Record**

1. Follow Steps 1, 2 above.
2. (M) Edit > Duplicate Record Above, to copy all field values from the previous record into the current record.

**Note:** Not all fields may be copied when using this feature, remember to check the fields before continuing.
Saving Your Work

When you save your work, Oracle Applications updates the underlying database with the work you have done since you last saved your changes and then informs you that the transaction is complete. Saving your work is sometimes referred to as committing a change or committing a transaction.

Oracle Applications always validates your work upon saving it. If any of the data you enter is invalid or missing, Oracle Applications displays a message describing the problem and does not save the data.

To save your work, use any of the following methods:

- (M) File > Save.
- (M) File > Save and Proceed. This will save any changes you have made to the current window and move to the next record (new or existing) so you can enter another transaction.
- Click the Save button in the Toolbar.
- Use keyboard shortcut [Ctrl] + [S].
Searching for Data Using Forms
Using the Find Window

1. (M) View > Find or click the Find icon on the toolbar.
2. Enter your search criteria in the appropriate fields of the Find window.
   - If a field does not provide a list of values for you to choose from, you can enter wildcard characters (%) and -) in the search phrase. You cannot, however, use query operators (such as >, <, and so on) in a Find window.
3. Click the Find button to find any matching records.
4. Click the Clear button to clear the current search criteria from the Find window so you can enter new search criteria.
Using Query Mode

1. (M) View > Query By Example > Enter
2. Enter search criteria
3. (M) View > Query By Example > Run
4. (M) View > Query By Example > Cancel

How to Use Query Mode
1. (M) View > Query By Example > Enter.
2. Enter search criteria in any of the queryable fields (indicated by blue), using wildcard characters and query operators as necessary. You can also select View > Query By Example > Show Last Criteria to display the search criteria used in your last search, if you performed one.
3. (M) View > Query By Example > Run to perform the search.
4. (M) View > Query By Example > Cancel to cancel from Enter Query mode.

How to Obtain a Query Count
1. Perform steps 1 and 2 above.
2. (M) View > Query By Example > Count Matching Records to display the number of records a Query By Example search would retrieve.
Using Query Operators and Wildcard Characters

You can use any of the query operators listed in the table shown in the slide. You can also use the percent “%” wildcard character to represent any character or group of characters. For example, use “Manuf%” to represent Manufacturing, Manufacturer, and so on. You can also use the underline “_” character to represent any single character. For example, “Product_” can represent ProductA, or Product1.
Retrieved Records

Reviewing Your Data
After a search, Oracle Applications retrieves any records that matched your search criteria. Always enter the most selective search criteria that you can.

How to Review Retrieved Records
Use the scroll bar to view additional records currently not visible on the screen in a multirecord block.

(M) View > Record First to see the first record.
(M) View > Record Last to see the last record.

Note: Scrolling through records and using the Record Last command uses significant system resources. Avoid this by entering selective search criteria.

The status line will indicate for instance Record: 1/3—this example indicates that the current record is one of three records in the current block. If an undetermined number of records have been retrieved, the message will appear as 1/? . Moving to the Last record will indicate the total number of records retrieved, although this can take a long time if there are many records, it is wise to use Query Count before performing such actions.
Accessing Online Help
This documentation will be available in the ORACLE MIS Intranet pages. In general it will be more useful to the user than the general help available in Oracle, since it is concerning with the completion of specific IITA tasks. Such as completing an MRI/RFP online etc. The exact location and names may be slightly different at the time of going live.
Using Window Help

Accessing Window Help
Oracle Applications provides you with a complete online help facility through your web browser tool.

How to Display Help for a Current Window
1. Select (M) Help > Window Help. A help window is displayed, providing information and a list of topics associated with the current application window.
2. Click on a topic of interest to display more detailed information.
Using Online Help

A Web browser window appears when you use the help system. This window contains search and navigation frames on the left part of the window, and a frame that displays the help information on the right side of the window.

The document frame can provide information on the application window containing the cursor, information on the topic selected in the navigation frame, or a list of topics that are a result of using the frame.

The navigation frame displays the top-level topics for your responsibility, arranged in a tree control.

If the document frame contains a list of topics associated with the window, you can click on a topic to display more detailed information.
Searching for Help Information

Searching

You can perform a search to find the Oracle Applications help information you want. Simply enter your query in the text field located in the top-left frame of the browser window when viewing help, then click the adjacent Find button.

A list of titles, ranked by relevance and linked to the documents in question, is returned from your search in the right-hand document frame. Click on whichever title seems to best answer your needs to display the complete document in this frame. If the document does not fully answer your questions, use your browser's Back button to return to the list of titles and try another.
### Search Syntax

<table>
<thead>
<tr>
<th>Use this syntax . . .</th>
<th>To find files containing . . .</th>
</tr>
</thead>
<tbody>
<tr>
<td>term</td>
<td>the word “term”</td>
</tr>
<tr>
<td>string*</td>
<td>words that begin with “string”</td>
</tr>
<tr>
<td>“words, and punctuation”</td>
<td>the precise phrase “words, and punctuation”</td>
</tr>
<tr>
<td>term1 OR term2</td>
<td>either term1 or term2</td>
</tr>
<tr>
<td>term1 AND term2</td>
<td>both term1 and term2</td>
</tr>
<tr>
<td>term1 + term2</td>
<td></td>
</tr>
<tr>
<td>term1 AND NOT term2</td>
<td>term1, but not term2</td>
</tr>
<tr>
<td>term1 - term2</td>
<td></td>
</tr>
</tbody>
</table>

### Using Search Syntax

The search syntax to use in constructing your query can be any of those shown in the table in the slide.

**Example**

You want to know how to create a budget organization in Oracle General Ledger. You enter “budget organization” in the search field, and click Find. A linked list of help documents that contain this phrase appears in the document frame. You click on one that seems appropriate and start reading.
The Library

You can access online help for any Oracle Applications product and you can reference that product’s documentation online as well. All of the applications are listed in the navigation frame on the left hand side of the window.
Error Messages

- To give you a hint, the application displays a short message in the message line.
- To inform you of an error, the application displays an error window.
- A History button also appears in the error window if an error of more serious nature occurs.

Error Message Codes

Generally, messages and errors are preceded by a message or error code. Codes that are prefixed by FRM arise from Oracle Forms, the underlying product that provides Oracle Applications with its graphical user interface. Codes that contain the prefix ORA arise from the Oracle database. Codes that are prefixed by APP arise from Oracle Applications. These codes help your system administrator or Oracle support representative diagnose the errors that you may encounter.
Learning About a Record

You can always display information about a record that has been previously saved. This record information includes who created the record, the date of creation, and the database table or view where the record resides. You can also learn who last changed the record using Oracle Applications, the date of the change, and that user’s logon and terminal information (if the terminal information has been specifically designated by your system administrator).

How to Learn About the Current Record

1. (M) Help > Record History. A window appears that shows you information about the current record.

2. Click OK to close the window.
Information About Oracle Applications

You can obtain details about the version of Oracle Applications you are using, your login information, and details regarding the current form you are using by using the About Oracle Applications window. This information is useful if you have an error message and need assistance from your system administrator or Oracle support representative when you report a problem.

How to Display Version Information for Oracle Applications

1. (M) Help > About Oracle Applications.
2. Click OK to close this window when you are finished.
Running Reports and Programs
Submitting a Request

How To Submit a Request and Define Parameters

1. Navigate to the Submit a New Request window. Select Reports and then Run.  
   (N) > Purchasing Requestor > Reports > Run

2. Check the Request option to submit single requests, or choose to submit a predefined group of requests by checking Request Set.

3. Click OK.

4. Use the Copy button to take advantage of previously entered request submissions. Or, select the Name of the request (report or program) that you want to run from the list of available requests. Note that the responsibility you are using determines the request group and the requests that will appear in the list.

5. A Parameters window automatically appears if you select a request that requires parameter values. The prompts in the Parameters window are specific to the request that you select.

6. Enter the values in the required parameter fields and click OK. The Parameters window closes, and your parameter values are concatenated and displayed in the Parameters window.
Defining a Submission Schedule

1. Click Schedule to open the Scheduling window.
   The scheduling window provides you with several scheduling options. You can choose to re-use a schedule you previously defined and saved, or define a new schedule. You can define your schedule to run a request as soon as possible, at a specific time, or repeatedly at specific intervals, on specific days of the week or month.

2. Choose a type of schedule.

3. To save your schedule, select the “Save this schedule for use again later” check box. You must also provide a unique name for each schedule you save, and you can provide additional information in the Description field.

4. Click OK. You are returned to the Submit Requests window.
Upon Completion

Defining Completion Options

1. In the Upon Completion region of the Submit Request window, check the Save all Output Files checkbox to write your request to a file. If you want to view your report online, you must use this check box.
2. Click the Options button.
   Specify additional people to notify using Oracle Workflow, upon completion of this report. You can also specify a language for the person if multiple languages are installed.
3. Select a print style.
4. Use the LOV to select the printers and languages you want used to produce a hardcopy of your report.
5. Enter the number of copies.
6. Click OK.
7. Click Submit Request when you are finished specifying scheduling and completion options.

After your request is submitted, Oracle Applications assigns a request ID to each request submission so that you can identify the results of the request when it is complete.
Finding Requests

Finding Requests

Viewing and Changing Requests

Since all reports, programs, and request sets are run as concurrent requests in Oracle Applications, you can navigate to the Request window to view the progress and output of all your concurrent requests, and you can change aspects of a request’s processing options. You can use the Request window (summary and detail) to view a list of all the submitted concurrent requests, check whether your request has run, change aspects of a request's processing options, diagnose errors, or find the position of your request in the queues of available concurrent managers.

How to Use the Request Window

1. Choose (M) View > Requests
2. Use the Find Requests window to specify the types of requests you want to see. You can choose to view your completed requests, your requests in progress, or all of your requests by selecting the appropriate option group.
3. Enter specific criteria in the Find window that appears, or click Find to display all of your requests that you have submitted.
4. Use the Order By poplist to specify the order in which you want your requests displayed.
Reprint

Reprinting a Report That Has Already Been Run

1. Navigate to the Requests window.
2. Query your request so that it is displayed as a record in the Requests window.
3. Select the specific request that you want to reprint.
4. To reprint a report, select Tools > Reprint from the menu.
Performing Concurrent Processing Tasks

**Refresh Data button:** The Requests window will not automatically refresh in order to display updated progress of your request. Use this button to requery the lines in the request table.

**Find Requests button:** Displays the Find Request window to perform a search for additional requests.

**Submit a New Request button:** Displays the Submit Requests window to submit a new request to the concurrent manager.

**Hold Request and Cancel Request buttons:** These buttons illuminate if the concurrent manager has not already begun running the program. You can Hold or Cancel a request by using these buttons. If the request is already running the Cancel button will terminate the request.

**View Details button:** Displays the Details window to view detailed information about your request, for example, submission dates, scheduling and other information. If a request has not already run, you can change selected fields so that the updated information will affect your request when it is run by the concurrent manager.

**Diagnostics button:** Displays diagnostic information about your request such as when it ran and if it completed successfully.

**View Output button:** Displays an online format of your report.
Performing Concurrent Processing Tasks (Continued)

Note: Reports that produce an output other than a text file (for example HTML or PDF) are displayed in a browser. If you set the profile option VIEWER: TEXT to Browser, your text files are also displayed in a browser as opposed to the Report Viewer.

View Log button: Displays information about the request regarding arguments used and other technical information

Screen colors help you identify the status of the request.

- **Green**: Pending, running or scheduled requests
- **Yellow**: Completed requests with a status of Warning
- **Red**: Requests that complete with a status of Error
Four Phases of a Concurrent Request

The Concurrent Requests Summary window displays a phase and status summary for each concurrent request listed in the window.

A concurrent request has a life cycle consisting of the following phases:

**Pending:** The request is waiting to be run.

**Running:** The request is running.

**Completed:** The request has finished execution.

**Inactive:** The request cannot yet be run.

During each phase, a concurrent request has a specific condition or status. The table lists each phase/status combination and describes its meaning in relation to a request.
Pending Phase

A program in the Pending phase can be in one of four statuses:

**Normal:** The program is waiting for an available manager.

**Waiting:** A child program is waiting for a parent to mark it ready to run.

**Standby:** A program is waiting for another incompatible program in the same logical database to complete.

**Scheduled:** A program’s scheduled start time has not yet elapsed.
Running Phase

A program in the Running phase can be in one of four statuses:

**Normal**: Program is in progress.

**Paused**: A parent program is waiting for one or more child programs to complete.

**Resuming**: A parent program is continuing after the completion of one or more child programs.

**Terminating**: The program is being terminated.
A program in the Completed phase can be in one of five statuses:

- **Normal**: Program completed successfully.
- **Warning**: Program completed successfully but with warning messages.
- **Error**: Program failed to complete successfully.
- **Terminated**: A running program was terminated.
- **Canceled**: A pending or inactive program was canceled before it started.
Inactive Phase

A program in the Inactive phase can be in one of three statuses:

**Disabled:** The requested program has not been enabled for execution.

**On Hold:** The requested program has been placed on hold.

**No Manager:** There is no manager defined to run this type of request.
Canceling or Holding a Request That Has Not Yet Completed

1. Navigate to the Requests window.
2. Select the Specific Request option button and enter the Request ID or other appropriate search criteria or select another appropriate option.
3. Click Find.
4. With the cursor on the request you want to cancel, click Cancel request. If the request is in Pending or Inactive phase, click Cancel Request or Hold Request to either cancel the request or put the request on hold. If the request is in Running phase, click Cancel Request to terminate the request.

   If you cancel a request set, then Oracle Applications will automatically cancel all requests in the set.

5. Choose Save from the File menu.
Changing Request Options

If your request or request set has not started running, you can change how your request or request set runs and prints its output by using the Requests window.

**How to Change the Request Options of a Request or Request Set**

1. Navigate to the Requests window.
2. Use the Find window to search for your request or request set ID.
3. Click Hold Request to put your request on hold.
4. You can change the start date and time for your request or request set. If the request is Pending or Scheduled, you can change the printer, the number of copies you want to print, and whether Oracle Application saves your report output to an operating system file. You can also change resubmission options in this window.
Managing an Attachment to a Form
The Disabled Attachments Icon

Identifying the Availability of Attachments

The toolbar Attachment icon indicates whether the Attachments feature is enabled in a form or block. When the button is disabled, the Attachments feature is not available. When the Attachments feature is enabled in a form or block, the icon becomes a solid paper clip. The icon switches to a paper clip holding a paper when the Attachments feature is enabled in a form block and the current record has at least one attachment.

You can use the profile option, Indicate Attachments, to turn off indications of attachments when querying records. This is an option you may use for performance reasons.
Adding a New Attachment

- Query or enter a data record.
- Click the Attachments toolbar icon.
- Enter a category and description.
- Type in your document text, or specify a file name or Web page URL.
- Save your work.

Attaching a Document to a Record

You can attach a document to any record for which attachments are enabled. For example, you can attach supplier notes to a purchase requisition (RFP).

**How to Attach a New Document to an Oracle Applications Record**

1. Query or enter a data record in an Oracle application window.
2. Click the Attachment toolbar icon. The Attachment window opens.
3. Enter a category and description.
4. Type in your document text, or specify a file name or web page URL.
5. Save your work.

**How to Attach an Existing Document to an Oracle Applications Record**

1. Click the Attachment toolbar icon. The Attachment window opens.
2. Click the Document Catalog... button. Query an existing document.
3. Check one or more documents, by holding down [Shift] and Clicking.
4. Click the Attach (number of documents) button.
5. Save your work.
What You Can Do with Attachments

- Copy attachments
- View an attached document
- Delete an attachment

Attachments
You can copy existing attachments to other data records. You can view attachments to any records, and delete attachments.
Copying Attachments

Oracle Applications keeps a catalog of documents that have been attached to applications data records. You can take advantage of this catalog if you want to attach an existing document to a second or subsequent data record.

If the document you want to attach already exists within Oracle Applications, click Document Catalog. When the Document Catalog window opens, query an existing document, check one or more documents, and then click Attach 1.

**How to Copy an Attachment from Another Record**

1. Query the record you want to attach a document to in an application window. (Do not query the record that already has the attachment.)
2. Click Attachments on the Toolbar.
3. Click the Document Catalog... button and enter query criteria in the Attached To: field for the application object you want to copy the attachments from.
4. Click the Find button and select a document.
5. Click the Attach 1 button.
6. Save your work.
Viewing Attachments

Viewing an Attached Document
1. Query a record.
2. Click the Attachment icon on the Toolbar.
3. Move the cursor to the document you want to view. The attachment appears in the document block or you must click the Open Document button to see the document in a browser.

Deleting an Attachment
When you delete an attachment, you merely remove the association between a record and a document. The document itself is not removed from your file system or database.

How to Delete a Record’s Attachment
1. Query a data record in an application window.
2. Click the Attachment icon on the Toolbar.
3. Move the cursor to the attachment that you want to delete.
4. Select Edit > Delete.
5. Click the Attachment button to delete the attachment or the Document and Attachment button to delete both.
6. Save your work.
Field Definitions of the Attachments Window

Use the Attachments window to view or delete existing attachments, and create new attachments. You must provide the following information when you create an attachment:

**Category**
The category provides information on who the attachment is for, such as “T Buyer”, “To Approver”, “Miscellaneous”, etc.

**Datatype**

- **Document Reference**—A reference to any type of document stored in a database that is accessed through a Document Management system.
- **Short Text**—Text stored in the database containing less than 2000 characters.
- **Long Text**—Text stored in the database containing 2000 characters or more.
- **File**—A file that requires other server applications to view, such as Microsoft Word or Microsoft Excel, image files such as .JPG files, or other types of files. When you attach or create a File type document, the document is loaded into the database. When a File document is selected, the lower half of the Attachments window displays an "Open Document" button that invokes a web browser and passes the file to the browser.
Attachments Window Fields

Field Definitions of the Attachments Window (continued)

Web Page—A URL reference to a web page that you can view with your web browser. You must define your web browser in the profile option Web Browser to view a web page attachment.

File or URL
If the document is a file, specify the location of the document. The document will then be loaded into the database. If the document is a web page, specify the web page URL.

May be Changed
The May be Changed checkbox indicates if you are able to edit the attachment.

Document Block
The document block is the section of the window below the multi-line attachment block. The document block displays the current document in the attachments block, or it displays an Open Document button that opens your document for viewing with a browser.

Attention: If you maximize the document block window, no other operations can be performed until you restore the block to its original state.
Customizing the Presentation of Data
What You Can Do with Folders

- Define folders
  - Name the folder
  - Define query criteria for the folder
  - Use folder tools to customize the presentation of data in the folder
- Open existing folder definitions
- Delete folder definitions

Using Folders

A folder is a special block in which the field and record layout can be customized. You can identify a folder from a regular block by noting that an Open Folder button appears in the upper-left corner of a folder block, or an enabled Folder Tools button appears on the toolbar when your cursor is in a folder block.

Although you have access to all of the records of a specific entity in a folder, you can customize a folder to retrieve only a subset of records and display those records in a specific layout. You can save your customizations to a folder definition, which defines the layout of your fields and the query criteria used to retrieve your subset of records.

An example is the Requisitions Summary screen, you could create a Folder called Incomplete Requisitions that only shows those requisitions with status Incomplete, and displays the Creation Date and Preparer fields. One or more Folder definitions can be saved per entity, such that screens can be designed appropriately for different tasks. Each Folder is, of course, restricted to data that the user is allowed to view based on the security rules of the product.
Defining a Folder

You can create and save new folder definitions or open and delete existing folder definitions. When you open a new folder definition, the layout for the new folder definition replaces the layout for the current folder definition.

**How to Create a New Folder Definition**

1. (M) Folder > New.
2. Enter a new and unique folder name.
3. Select the Autoquery frequency in which you want the folder to automatically query for a subset of records each time you open the folder definition.
4. Select Open as Default if you want this specific folder definition to open as your default each time you navigate to this form for the first time.
5. Select Public if you want other Oracle Applications users to have access to this folder definition.

**Note:** Users can never see records that violate basic security rules, regardless of any search criteria you specify in a folder.
6. Click OK when you are finished.
Querying Records in a Folder

- Define query criteria
  - Always
  - Never
  - Ask each time
- Open as Default
- Public
- You can reset the query criteria by selecting (M) Folder > Reset Query

Defining Query Criteria for a Folder

One advantage of a folder is that you can customize it to display only the records you want to see. You can easily define and alter the query criteria for any folder and save that criteria in a folder definition.

How to Define Query Criteria for a Folder

1. Run the query that you want, either by using Query Find or Query-by-Example. At least one record must be retrieved for the folder to memorize the query.
2. (M) Folder > Save As, if you want to save this query criteria in a new folder definition.
3. Enter a name for the folder definition.
4. Check Always from the Autoquery option group if you want this query to be performed every time you open this folder definition.
5. Click OK when you are finished.

When you save a folder definition, the query criteria is “locked in” to the folder definition. When you perform another query on that same folder definition, you actually query on the subset of records. If you want to perform a new Query-by-Example on the complete set of records, reset the query for the folder definition.
Resetting Query Criteria

Resetting the Query Criteria for a Folder Definition

1. (M) Folder > Reset Query, to clear the WHERE clause from the current folder definition, but it will retain the current folder name and its field layout. To view the query criteria for a folder definition, (M) Folder > View Query.

2. Perform another query and (M) Folder > Save to save the new query to your current folder definition.

3. To alter the sorting order of data in a multiple-record folder definition, (M) Folder > Sort Data.

4. Choose one of the following sort options:
   
   Ascending, Descending or Unsorted

   Note: Only the first three columns of a folder can be sorted.

5. Select View > Query By Example > Run to rerun the query in your folder definition to apply any ordering changes to the records.

6. Select Folder > Save or Folder > Save As to save this query criteria to a folder definition.
Accessing Folder Tools

When you navigate to a folder block, the Folder Tools button becomes enabled on the Toolbar. Click this button to display the folder tools on your screen.
Using Direct Manipulation Techniques on Folders

You can directly manipulate folder columns using the following techniques:

- Drag the right edge of a prompt to resize the column.
- Drag the center of the prompt to resequence the columns.
- Delete the prompt to hide the column.
- Left-click on the first three prompts to sort them.
- Right-click on any prompt to change the label.

For more on using folders, see *Oracle Applications User’s Guide* online help.
More Folder Tasks

- Recovering Original Folder Definition
  - (M) Folder > Save As
  - Clear the check box called Open as Default,
  - OK
- Opening Another Folder Definition
  - (M) Folder > Open
  - Select a private or public folder definition
  - OK to replace current folder definition

Recovering the Original Default Folder Definition for a Folder

Once you create a custom folder definition and make it the default, you can recover the original default folder definition shipped with the product. Note that if you like the original default folder definition, give it a name and save it (without making any changes) before you create any new folder definitions. This way, you can open the original folder definition by choosing it from a list of all your predefined folder definitions.

1. With the folder currently specified as the default displayed, (M) Folder > Save As.
2. Clear the Open as Default option in the Save As window.
3. Click OK when you are finished.
4. Navigate to this form again to display the original default folder definition.

Opening Another Folder Definition

1. (M) Folder > Open to load a predefined folder definition. Or, click the Open Folder button located in the upper left corner of the folder block.
2. Select a private or public folder definition from the list window that is displayed, and click OK to replace the current folder definition with the new folder definition.
More Folder Tasks

- Saving Changes to a Folder Definition
  - (M) Folder > Save As or Save
  - Type a name or keep the same name
  - OK

- Deleting a Folder Definition
  - (M) Folder > Delete
  - Select a folder
  - OK

Saving Changes to a Folder Definition
1. (M) Folder > Save to save any layout or query changes made to the current folder definition or (M) Folder > Save As to save the current folder definition under a new name.
2. Click OK after you have completed the information requested in the Save Folder window.

If you save a folder definition to Open as Default and then open another folder definition and save that second definition also as Open as Default, the second definition is reset as the new default.

If you modify a public folder definition in any way, saving it makes a copy of it that is a private folder definition.

Deleting a Folder Definition
1. Select Folder > Delete.
2. Select a folder definition from the list that is displayed and click OK to delete the definition.

Note that you can only delete folders you have created. If another user is referencing that folder definition as their Open as Default folder, that reference is deleted as well.
Setting Personal Profile Options
Setting Personal Profile Values

Your Personal User Profile
You can change a user profile option value using the Personal Profile Values window, where you can display all your options and review the values your system administrator has set for them. Your user profile options assume the values your system administrator has set for them at the various levels.

How to Change a Profile Option Value
1. (M) Edit > Preferences > Profiles.
This window displays all your user profile options and their values. If you wish to display only specific user profile options, first choose View > Query By Example > Enter to enter search criteria in the Profile Name field, then choose View > Query By Example > Run to run the search.

The name of the user profile option appears in the Profile Name field while the Default Value field displays the run-time value of that option. The System Administrator sets default values for many of the profile options. Some profile options may not display a default value.

2. Move your cursor to the User Value field of the option whose value you wish to modify.
3. Enter a new value for the option if it is updateable, or if the List icon appears, choose a value from the list of available values.
Profile Option Values

- User values override default values.
- Values are validated, except for number or date values.
- You cannot delete a profile option, but you can clear the value.

Your Personal User Profile (continued)

If the profile option is not updateable, the message “Item is protected against update,” appears on the message line when you try to change the value. You can change most of your user profile options; values you enter in the User Value field override values preset by the System Administrator. A few profile options cannot be changed, but are displayed for informational purposes only.

For most personal profile options, Oracle Applications automatically checks the value you enter to ensure it is valid.

Attention: Number or date values are not validated, therefore, you must make sure that you enter a valid value for profile options that require a number or date; otherwise, your personal profile option may not work as you expect.

Though you cannot delete a profile option from your personal profile, you can clear its value (if it is updateable) by highlighting the field and pressing [Backspace] or by choosing Clear, Field from the Edit menu. If you clear the value, the change does not take effect until you sign on again or change responsibilities.

4. (M) File > Save to save your change.

Your change will take effect when you either change responsibilities or log out and log back in.
### Personal Profiles Values

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Concurrent: Hold Requests</td>
<td>Specifies whether to hold a request temporarily, until you remove the hold</td>
</tr>
<tr>
<td>Concurrent: Report Copies</td>
<td>Specifies the number of copies of a report to print</td>
</tr>
<tr>
<td>Concurrent: Request Start Time</td>
<td>Specifies the date and time for a request</td>
</tr>
<tr>
<td>Concurrent: Sequential Requests</td>
<td>Specifies whether to run requests sequentially</td>
</tr>
</tbody>
</table>

### Defining Personal Profiles Values

All reports and programs in Oracle Applications run as concurrent processes whether you submit them using the Submit Requests window or a product-specific submission window. Submitted reports and programs are referred to as *concurrent requests*. Each concurrent request runs according to a set of concurrent processing options.

The Personal Profiles Values window sets the defaults for these profiles. If you want to change the value of a default, you must change the value of the corresponding user profile option using the Personal Profiles Values window in your application.
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Concurrent: Save Output</td>
<td>Specifies whether to save report output to a file</td>
</tr>
<tr>
<td>Printer</td>
<td>Specifies the printer for printing your report output</td>
</tr>
<tr>
<td>Concurrent: Show Requests Summary After Each Request Submission</td>
<td>Display Requests Summary each time a request is submitted or not</td>
</tr>
<tr>
<td>Viewer: Default Font Size</td>
<td>Set default font size for report output in the Report Viewer window</td>
</tr>
</tbody>
</table>
Hints and Tips

- I typed some data in a field and I can’t continue?
- The “Field must be entered” message
- “No entries found for List of Values”

I typed some data in a field and I can’t continue?
Typed something into a field and it seems to be stuck? Check the Message Line! Example messages are “Invalid value for field :??????”, “Not a valid month”, etc.
Maybe you did not enter valid information, for example if you have typed into a field that has a LOV, the text you enter must be in the LOV, otherwise it will not be accepted.

The “Field must be entered” message
Yellow fields are required fields, you cannot complete a form if any of these fields are blank.
The field must be entered message is informing you of this.
The most common problem is when you first enter a form and start to type into a field attempting to use Find or Query. If you forget to select the Find icon on the toolbar or forget to choose (M) Query By Example > Enter to enter query mode first, the system will assume you are entering a NEW record.
When you realise your mistake and try to move to Find or Query, the system will display the “Field must be entered” message in the Message Line if there are empty required (yellow) fields.
To solve this click on the Clear Record icon on the toolbar. If this doesn’t work then choose (M) Edit > Clear > Form.
“No entries found for List of Values”
Sometimes you are convinced that there should be items listed when you select the list of values, but you receive the above message.
Check your search criteria, remember some lists are case sensitive. For example, if the items you are searching for are in uppercase, your list of values may not work if you search for them as “m%” since the items actually begin “M%”